Bug#672644: X on Mobility Radeon HD 3400 Series (Lenovo T400) broken after wheezy upgrade

Michel Dänzer daenzer at debian.org
Mon May 14 03:33:08 PDT 2012

On Mon, 2012-05-14 at 10:56 +0200, Josip Rodin wrote: 
> On Sun, May 13, 2012 at 11:00:46PM +0200, Julien Cristau wrote:
> > > In any case, I rebooted using SysRq+S+U+B (I think, at least - couldn't see
> > > anything) and installed firmware-linux-nonfree, rebooted once again for good
> > > measure, and tried startx again, and now it just aborts X saying:
> > > 
> > > [   137.038] (EE) RADEON(0): [dri] RADEONDRIGetVersion failed because of a version mismatch.
> > > [dri] This chipset requires a kernel module version of 1.17.0,
> > > [dri] but the kernel reports a version of 2.12.0.
> > > [dri] Make sure your module is loaded prior to starting X, and
> > > [dri] that this driver was built with support for KMS.
> > > [dri] Aborting.

I'm afraid that's as good as it gets. When using a display manager, it
should automatically try starting the X server again, which should

> > Means your radeon kernel module is not being properly loaded by udev.
> > You need to figure out why.
> There's nothing strange about it, at least none that I can see.
> You can see in the attached dmesg output that it worked fine.

dmesg can't tell you why the kernel module wasn't loaded by udev.
Usually it's due to a stale blacklist entry in the udev/modprobe

Earthling Michel Dänzer           |                   http://www.amd.com
Libre software enthusiast         |          Debian, X and DRI developer

More information about the xorg-driver-ati mailing list