[Bug 52590] Segmentation fault when trying to use radeon HD 7500 series card

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Fri Jul 27 20:57:22 PDT 2012


--- Comment #2 from Davey <daveywalbeck at gmail.com> 2012-07-27 20:57:22 PDT ---
(In reply to comment #1)
> Can you install debugging symbols and get a proper backtrace the gdb?
> http://wiki.x.org/wiki/Development/Documentation/ServerDebugging
> Also, please attach the dmesg output for your system.

Sure thing, I'll add the dmesg file.  As for the debugging symbols, I'm sure
sure I'm clear on how to accomplish that.  I followed the link provided and
tried to do what I understood to do, which is to say I logged in from another
machine and entered:
gdb /usr/bin/Xorg $(pidof X)

The output of which was:
GNU gdb (Gentoo 7.3.1 p2) 7.3.1
Copyright (C) 2011 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-pc-linux-gnu".
For bug reporting instructions, please see:
Reading symbols from /usr/bin/Xorg...(no debugging symbols found)...done.

I then tried to start an X session on the machine itself, while leaving that in
it's current state, but nothing ever changed or output to the remotely
connected machine running debug.  The failure output on the machine itself was
the same:  Caught signal 11 (Segmentation fault)

Am I not doing what you need correctly?

Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the xorg-driver-ati mailing list