[Bug 46314] New: Failure to return to text mode on leaving X

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Sun Feb 19 20:44:12 PST 2012


             Bug #: 46314
           Summary: Failure to return to text mode on leaving X
    Classification: Unclassified
           Product: xorg
           Version: unspecified
          Platform: x86-64 (AMD64)
        OS/Version: FreeBSD
            Status: NEW
          Severity: major
          Priority: medium
         Component: Driver/Radeon
        AssignedTo: xorg-driver-ati at lists.x.org
        ReportedBy: pukku at mac.com
         QAContact: xorg-team at lists.x.org

Hi! I have a Thinkpad X120e (a netbook). It reports itself as having an "Advanced Micro Devices [AMD] nee ATI Wrestler [Radeon HD 6310] rev 0" card, and lists
the chipset as "AMD Radeon HD 6310 Graphics (ChipID = 0x9802)".

I'm running FreeBSD 9.0.

I've installed the x11/xorg port.

When I run using the "vesa" driver, X works fine, and leaving X works correctly as well. However the screen is 1366x768, and Vesa only supports 1024x768.

If I try to use the "radeon" driver, X seems to work fine (I admit, I've only gotten as far as `Xorg -config xorg.conf.new -retro`). But if I try to leave X --
using Ctrl-Alt-F1 to get back to the first virtual console -- the retro pattern disappears, but nothing appears on the screen.

If I go back to the X buffer using Ctrl-Alt-F9, the display is now offset, so that in the middle of the screen is a big black bar, and the retro pattern is on
either side of the bar, and if I move the mouse pointer towards the right, it wraps around to the left side of the screen.

If at the -F1 virtual console I hit Ctrl-C, nothing happens -- the text doesn't reappear. However, the computer is not hung. I can restart it using the
`shutdown` command. I can even go to other virtual consoles (which still don't display anything), log in, and shut down the computer.

I have tried using `vidcontrol 80x30` at the text console to restore the screen, but it has no effect.

I have tried to use the version of the module from git (git clone; autogen.sh; make; make install), but this still shows the same behavior.

Just for fun, after I hit Ctrl-C back at the first virtual console, I tried to restart X (using the -retro incantation again), and this time there was a dotted
gray line at the top of the screen, and nothing else. However, it still allowed me to restart the computer blind.


Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the xorg-driver-ati mailing list