Stuttering / Frame drops with RS880/785G and AMD Bulldozer CPU

Michel Dänzer michel at
Tue Feb 14 02:23:51 PST 2012

On Mon, 2012-02-13 at 13:05 +0200, Shahar Or wrote: 
> A Live image of Ubuntu Desktop 12.04 amd64 was also tested. It had the
> same stuttering / framedrop.

Have you tried a live image of a different distro?

> 2012/2/9 Michel Dänzer <michel at>
> >
> > On Don, 2012-02-09 at 02:03 +0200, Shahar Or wrote:
> > >
> > > Since replacing an AMD Sempron 140 with an AMD FX-4100 CPU in my
> > > system
> >
> > Literally only replacing the CPU in the socket, nothing else changed?
> Actually, as per Gigabyte's instructions(2), in order to have support
> for this CPU, I upgraded the BIOS from the "F2" version to the "F3"
> version before replacing the CPU (flashrom FTW!) If it is necessary, I
> can put in the old Sempron 140 CPU for testing.

That might be interesting once we're running out of things to try with
the new CPU.

> So I ran sysprof, which is an easy GUI and to my content I only needed
> to press a "Start" button :). That's when the magic happened. From the
> moment it starts the stuttering goes away. Sweet rendering smoothness
> of divine electrical display benefaction ensues! And from the moment I
> press "Profile" to stop it, it stops and stuttering returns OMG. And
> this is perfectly persistent. What does this mean?

Not sure...

Which cpufreq governor is being used? Assuming it's one that dynamically
changes CPU core frequencies, such as ondemand or conservative, does the
problem go away if you switch to one that doesn't, e.g. performance or

Earthling Michel Dänzer           |         
Libre software enthusiast         |          Debian, X and DRI developer

More information about the xorg-driver-ati mailing list