[Bug 37679] [RS690M] No 3d acceleration in Radeon X1200 with the new Gallium r300 / 3d drivers

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Wed Sep 7 20:34:19 PDT 2011


--- Comment #54 from André Oliva <gandreoliva at gmail.com> 2011-09-07 20:34:17 PDT ---
(In reply to comment #53)
> So it seems the bug got a bit sidetracked by that speed issue, but regardless
> of that, the underlying issue doesn't seem to have been addressed: both
> reporters seem to need the 'noapic' or 'irqpoll' workarounds to get things
> flying at all. Is anything happening to address the fundamental bug?

When I tried Fedora 15 from Live USB, I could *not* start Gnome 3 (--> bad 3d
acceleration --> the same bug) [blank screen and the pinter]. I used uNetbootin
to create the Live USB, and even if I tried to add "noapic" to the boot line,
it didn't work. Also I tried killing the X server, running "export
vblank_mode=0" and "export CLUTTER_VBLANK=none" and restarting X server and
also didn't work. Of course, I didn't tried installing Fedora 15, and then
retrying the workaround, but at least from Live USB I couldn't make it work.

However, I noticed that when Gnome 3 loads and the freeze happens, and then I
press ALT+F2, kill gnome-shell, and then ALT+F8, the Gnome-shell elements (top
panel and dash) appear in the screen, but of course I can not use it because I
killed the process. It's may be a clue.

Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the xorg-driver-ati mailing list