[Bug 35479] New: Imac Radeon HD 4850 switch "Mini Display Port" output during install resulting black screen

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Sun Mar 20 22:13:07 PDT 2011


           Summary: Imac Radeon HD 4850 switch "Mini Display Port" output
                    during install resulting black screen
           Product: xorg
           Version: unspecified
          Platform: x86-64 (AMD64)
        OS/Version: Linux (All)
            Status: NEW
          Severity: normal
          Priority: medium
         Component: Driver/Radeon
        AssignedTo: xorg-driver-ati at lists.x.org
        ReportedBy: ihatewindowsxp at gmail.com
         QAContact: xorg-team at lists.x.org

Forwarding  bug from 

Reported by artik on 2010-06-22
Bug Description

I tried to install Lucid on the new Apple Imac27" with ATI radeon HD 4850 video
card. After selected "install", the screen goes black. few investigations
later, I discovered display output switch to the Mini Display Port. So, I tried
to connect a second screen, and I was right : just after select "install
lucid", the video output switch to the second screen, and the main screen turn

I continue my installation using my 2nd screen (connected to the mini display
port), and after it, I'm on the desktop. I activate Open radeon drivers, they
works perfectly, but in the second screen (Vsync is perfect, and very smooth
using compiz). Impossible to switch to the main screen. It's not recognized,
and stay black.

I tried proprietary ati drivers (10.6). With them, I can activate my main
screen, but they are not better than the open ones : there is a big vsync bug.
Actually, It's totally impossible for a normal user to use open ati drivers on
the main screen with an Imac27 and ati radeon 4850 graphic card.

I think issue is in the kms driver, I tried to deactivate them. Main screen is
recognized, but impossible to turn it on, it stay black, and Vsync issue
re-appear on the second screen. Maybe the open radeon drivers also got a bug,
cause after deactivate them, my main screen is now recognized on display
manager, but impossible after activate it, it stay black => back to proprietary
drivers, and the Vsync issue)

i tried 2.6.32, 2.6.34, 2.6.35 rc1 released, bug is still here.
attachments to original report:

Additional comments:
Peter T Hayward wrote on 2010-09-25:     
I've been suffering this problem on my new iMac 21.5 (11,2 i3, Radeon 4670).
All linux live CDs would give black screen even though I could hear the disc
loading up.

I've got round the problem for my system by doing two things:
1 connecting an external monitor through the Mini Display port.
2 Using F6 on the grub boot menu to add options - radeon.modeset=0 nomodeset

I don't know if the radeon modesetting works on the external monitor (LG1710,
has worked OK on a Mac Mini but will test it on iMac) but it certainly doesn't
work on the main monitor.
I've only tried live CDs so far; in 'xrandr' the main monitor is identified as
eDP-0 and it lists the full range of supported resolutions up to 1920x1080.

Peter T Hayward wrote on 2010-09-26:     
Radeon modesetting does not work on my LG1710. I can only get it to light up if
I use the two options above.

MountainX wrote on 2010-11-02:     
This issue is affecting me too. I verified that this is the exact behavior I'm
seeing with my iMac 11,1. This issue does not affect all model iMacs. Mine is a
27" late 2009 model.

Here is how to check the serial number to determine the model.

On the bottom of your iMac stand, you'll find a label with the serial number
printed on it, or from the Apple menu, choose About This Mac. Configure To
Order (CTO) models are designated with an asterisk (*). Check the last three
characters on the serial number:
iMac (Mid 2010)
DAS, DNM* iMac (21.5-inch, Mid 2010)
DB7, DNN* iMac (21.5-inch, Mid 2010)
DB6, DNP* iMac (27-inch, Mid 2010)
DB5, DNR* iMac (27-inch, Mid 2010)
iMac (Late 2009)
5PC, B9U, CY8* iMac (21.5-inch, Late 2009)
5PK*, B9S* iMac (21.5-inch, Late 2009)
5PE, 5PJ, CYB* iMac (27-inch, Late 2009)
CYC*, 5PM*, 5RU* iMac (27-inch, Late 2009)

Brad Figg on 2010-12-03
tags:     added: acpi-apic
Richard Holmes wrote on 2011-02-27:     #8
I believe I have the same problem with a Mid 2010 21.5-inch iMac (serial ends
in DAS). Trying to boot from a Mint 10 Live DVD, screen goes black early in the
boot process. If I put 'nomodeset' or 'radeon.modeset=0' on the boot line I see
text until after the "welcome to Linux Mint" message, command line prompt
appears, then after some delay it goes to black screen again. If I put 'text'
on the boot line I can boot into text mode and text display remains visible. I
do not have an external display readily available to check if output is
switching there.

Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the xorg-driver-ati mailing list