[Bug 38689] New: Black xorg screen with kernels newer than 2.6.34.x

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Sun Jun 26 03:11:48 PDT 2011


           Summary: Black xorg screen with kernels newer than 2.6.34.x
           Product: xorg
           Version: 7.4
          Platform: x86-64 (AMD64)
        OS/Version: Linux (All)
            Status: NEW
          Severity: blocker
          Priority: medium
         Component: Driver/Radeon
        AssignedTo: xorg-driver-ati at lists.x.org
        ReportedBy: jmarcet at gmail.com
         QAContact: xorg-team at lists.x.org

Created an attachment (id=48426)
 --> (https://bugs.freedesktop.org/attachment.cgi?id=48426)
2.6.34 dmesg


I have an old HTPC, with an older yet Soltek motherboard, AMD64 939, and a
Radeon 9000 (r200).

I had been using a quite old kernel, 2.6.32, because I got no video output with
newer ones.

These days I've had some time to test things out and I am now running 2.6.34
where everything works fine, however with any newer kernel I do have a usable
kms console but a black screen on xorg.

I tried every major stable kernel between 2.6.32 and 2.6.39 (vanilla kernels).
Xorg server between 1.9.4 and, mesa between 7.9.2 and 7.10.3, and
forcing different resolutions, on both VGA-0 and DVI-0 outputs; yet I can't get
video working on 2.6.35+ kernels.

I even tried with XAA, disabling ColorTiling, PCI bus type, disabling AGP Fast
Writes, disabling DRI, ... to no avail. Nothing works with a sync extension
enabled kernel.

I attach the logs I found relevant.

You can see the any differences in xorg between a working 2.6.34 kernel and a
failing 2.6.35, are a quite longer EDID dump under 2.6.35 and the sync
extension which was included on that kernel, which also enabled two new GL
extensions, GLX_SGI_swap_control and GLX_MESA_swap_control.

Everything else looks exactly the same.

On my TV, which I connect from the DVI-0 output to a HDMI input (although I
also tried through VGA), I can see it sets the video mode correctly,
1920*1080 at 50. In fact the kms console works fine all along.
Even with the black xorg screen, I can switch back to a kms console and it

I considered doing a bisect between 2.6.34 and 2.6.35 but there are far too
many commits within drm for it to be feasible (it is not exactly fast this

If you have any ideas where might be the problem or anything else which might
be useful to fix this, I'd be really grateful.

Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the xorg-driver-ati mailing list