[Bug 37679] [RS690M] No 3d acceleration in Radeon X1200 with the new Gallium r300 / 3d drivers

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Thu Jun 9 12:58:31 PDT 2011


--- Comment #32 from André Oliva <gandreoliva at gmail.com> 2011-06-09 12:58:31 PDT ---
(In reply to comment #30)
> (In reply to comment #29)
> > 
> > So I tried rebooting with "irqpoll" in the kernel options.  KDE4 and GNOME3
> > (gnome-shell) both run. glxgears gives 50 FPS !!
> > 
> > So, my guess is the kernel/drm/radeon is wedging on interrupt processing.
> Sounds like your board bios has screwed up the irq routing which is not
> something we can fix in the driver unfortunately.
>         irqpoll         [HW]
>                         When an interrupt is not handled search all handlers
>                         for it. Also check all handlers each timer
>                         interrupt. Intended to get systems with badly broken
>                         firmware running.

But I have never made an upgrade of BIOS, and 3d acceleration worked in Ubuntu
10.04, but now it doesn't work. In fact, right now I can boot into 10.04 and 3d
acceleration works. Isn't the driver responsible for that behavior?

Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the xorg-driver-ati mailing list