Bug#586485: Regression: can't resume after suspend-to-RAM

Dave Platt dplatt at radagast.org
Mon Feb 14 12:01:33 PST 2011

I've learned of an effective workaround for the problem via
another open bug (#565344), and this workaround probably points
to the source of the problem.

The workaround:  go into /etc/modprobe.d/, find the file
which has the options for the "radeon" module, and change
"modeset=1" to "modeset=0".  Reboot.  Problem fixed.

It appears that on some Radeon chipsets, having the kernel
mode-setting enabled will cause this black-screen problem after
wakeup from a suspend or hibernation.  Explicitly disabling
KMS via this option, resolves the problem.

The problem doesn't seem to be unique to particular versions
of the kernel, or even to specific versions of the Radeon driver
and module.  I've tried both custom-built kernels, and the standard
Squeeze kernel... no difference.  In one of the other bug reports
on this problem, a poster even tried switching back and forth between
Debian and Ubuntu driver installs, and the problem did not follow the
installs in any predictable way... once the problem appeared,
reverting back to a kernel and driver pair which had previously worked,
still exhibited the problem.  However, when he did a fresh install
of this software on a different system (same chipset) it worked!

The difference, apparently, is the contents of the module configuration
file... if it says "modeset=1", resume is broken, and if you say
"modeset=0", everything works.

It seems likely that the problem first occurred on my machine, when
I did a regular Debian "testing" upgrade, which picked up a deb package
of the Radeon driver that added "modeset=1" to the driver options.

When I looked back through the logs I uploaded back in July, I
noticed something curious... the driver reported that KMS was being
disabled due to some sort of incompatibility.  It appears, though,
that having "modeset=1" in the driver options was enough to cause the
problem to occur, even though kernel modesetting had been disabled
by the driver.

In any case:

(1) I have a workaround and am happy once again!

(2) It looks as if there may be some loopholes in how kernel modesetting
     is done for at least some of the Radeon chips, which causes the
     black-screen problem upon wakeup if kernel modesetting is not
     explicitly disabled.  This problem may affect the Mobility X700
     and has also been reported on the 4200... others may also be

More information about the xorg-driver-ati mailing list