Bug#637958: X.org crash leaves GPU in an inconsistent state and renders system unbootable

Michel Dänzer daenzer at debian.org
Tue Aug 16 00:27:09 PDT 2011

On Die, 2011-08-16 at 00:21 +0100, Martin wrote: 
> Package: xserver-xorg-video-radeon
> Version: 1:6.13.1-2+squeeze1
> Working with an IBM^WLenovo ThinkPad T60 with an ATi Mobility X1400
> (R520) with a fresh install of Debian Squeeze.  Have attached:
> *. lspci -vv list hardware
> *. uname -a, output of dmesg after boot and list of modules
> *. dpkg --list giving package versions (note that linux-firmware-nonfree
> is NOT installed)
> *. The output of radeontool regs after the kernel radeon driver has been
> loaded and X started.
> *. X version information and X log, the system has no X configuration
> file.
> Machine boots and starts X OK.  X runs normally for a while, althought
> there is no 3D acceleration.  After a few minutes of using X the machine
> freezes.  There is no consistent trigger for this but it is often
> correlated with opening or closing windows or rendering content in the
> web browser.  I've tried to contact the machine from another box with no
> luck and a loop set to eject the cd every 120 seconds stops working so I
> am fairly convinced it frozen.
> On rebooting the machine consistently fails to boot.  The exact point at
> which it freezes varies but it always after the drivers are loaded.
> Booting with init=/bin/sh and manually loading the drivers confirms that
> it is the radeon driver that hangs the machine.  Disconnecting the
> machine from mains power, removing the battery and leaving for > 5
> minutes does not resolve this problem.
> The only way (I've found) to return the machine to a bootable state is
> to take an old Debian boot CD (Debian 4.0r0 netinstall.iso) and boot
> from that.  It runs kernel 2.6.18-4-486 and does not load any radeon
> specific drivers, it uses vga16fb and does not run X.  Booting from this
> appears to be enough to reset the card and then I can boot squeeze as
> before.


> Other things I've tried:
> *. The same set up on another machine -- the problem is reproducible so
> I don't think it is a hardware fault.

What GPU does the other machine have?

> *. Installing linux-firmware-nonfree, this gives the same problem but
> when setting:
> options radeon modeset=0
> in /etc/modprobe.d/radeon-kms.conf, DRI and 3D acceleration work.
> However neither change resolves the problem.

Please provide dmesg and Xorg.0.log with linux-firmware-nonfree
installed and modeset=1.

Earthling Michel Dänzer           |                   http://www.amd.com
Libre software enthusiast         |          Debian, X and DRI developer

More information about the xorg-driver-ati mailing list