[Bug 31974] starting X with EXA, DRI enabled locks up the system (evergreen mobility card)

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Sat Apr 30 05:16:10 PDT 2011


--- Comment #18 from aceman <acelists at atlas.sk> 2011-04-30 05:16:10 PDT ---
This happened to me again. I was on kernel I noticed my kernel
drivers for my v4l TV capture card were missing. The compile options propably
changed since (2.6.36 or .37) and I didn't notice so the modules got compiled
out. So I compiled them and loaded into the running kernel. They worked fine.
However, when I logged off the KDE session, kdm should have appeared. This
didn't happen and I got a black screen again. I think the X server restarts
when the session is logged off. So I tried to reboot but when X was starting I
got this bug again (black screen). Trying several reboots I determined that
kernel doesn't work since now, but works (it does not have
the v4l modules). So blaming the v4l kernel modules I removed loading the v4l
module from the X server config. And guess what, X server started now fine with The module version is 0.1.1 (according to Xorg.log), compiled for
server 1.9.2. So, can this be caused by the removal of v4l API version 1 from
the kernel. I read the v4l X module needs to be updated for this change.
However, I find it strange that this module affect the main radeon module in
any way. I would have thought the X server would hang at loading the v4l module
if it doesn't find the proper kernel APIs. But the attached log (comment 4)
shows hang much later.

Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the xorg-driver-ati mailing list