[Bug 36424] New: X crashes in KDE4 with compositing enabled

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Wed Apr 20 07:41:19 PDT 2011


           Summary: X crashes in KDE4 with compositing enabled
           Product: xorg
           Version: unspecified
          Platform: x86-64 (AMD64)
        OS/Version: Linux (All)
            Status: NEW
          Severity: major
          Priority: medium
         Component: Driver/Radeon
        AssignedTo: xorg-driver-ati at lists.x.org
        ReportedBy: wonko at wonkology.org
         QAContact: xorg-team at lists.x.org

Created an attachment (id=45863)
 --> (https://bugs.freedesktop.org/attachment.cgi?id=45863)
Xorg log file

Since KDE 4.6.0, I see nasty artefacts with the radeon driver in most
applications when scrolling. They are less severe when compositing is turned
off, but there are not gone altogether, and I like the desktop effects. And I
am running an outdated version of X (1.7.7) anyway (because I had trouble with
newer versions), so reporting the bug probably makes no sense.

So I tried to upgrade again. But while it seems to work fine with normal window
managers, a KDE4 session crashes after a few minutes, without any apparent
reason. With compositing disabled, KDE4 is runnig fine, too. I tried
xorg-server and 1.9.5, the latter with and without KMS kernel option
set, and the backtrace in Xorg.0.log looks quite the same. My X is built with
gallium support, but I turn it off via the nomodeset boot parameter. If I do
not do this, the boot process hangs when settings the text font, and I see my
Grub boot splash image in wrong colors and distorted. Gallium used to work in
1.7.7, but then I had no text mode at all, and had to wait for X to start in
order so see anything on the display. It was also slower.

My graphics adapter is an on-board Radeon HD 3200. I am running Gentoo Linux an
amd64, with kernel 2.6.38-ck, xorg-server 1.9.5, xf86-video-ati 6.14.1. BTW, I
have no idea how the version numbers 6.7.0 to 7.6 relate to my versions, so I
left them unspecified.

My workaround is to use the fglrx driver. It is working, but I have memory
problems when using it, and already had them in the past. Don't know what's
going on, but my system starts swapping early, and after a day of KDE4 usage I
have to log out and in again in order to free memory. So I would like to switch
back to radeon.

I tried to get better debug output, recompiled Xorg-server and xf86-video-ati
with debug information, and started X with gdb --command=cmdfile according to 
http://www.x.org/wiki/Development/Documentation/ServerDebugging . But then I
only get a blank screen with a cursor blinking at the top left, and when I try
to switch back to a text console (I have to use Alt-SysRq-R/K before), my
display goes into suspend mode. I am back at the text terminal, but I am blind,
and have to reboot. Any idea why this is, and what I could do about it? I know
this effect from past experiences, when I switch the graphics drivers. Normally
switching back to the text console works after Alt-SysRq-R, but only once. But
since I changed to the radeon driver one year ago, this did not happen any

So, this problem forces me to not use the radeon driver and use fglrx instead,
which also has problems. I hope this can be fixed. But I guess you really
_need_ the debug output, huh?

Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the xorg-driver-ati mailing list