[Bug 36007] [natty] system freezes on boot without disabling KMS

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Fri Apr 8 04:20:42 PDT 2011


--- Comment #10 from Gabor Lenart <spam at lgb.hu> 2011-04-08 04:20:42 PDT ---
(In reply to comment #9)
> You have to load the drm before X has started.  Try the following:
> 1. Add "radeon.modeset=0 single" to the end of your kernel command line in
> grub.  That should boot into single user mode without X running.
> 2. At the console (do not start X) enter the following commands:
> modprobe -r radeon
> modprobe fbcon
> modprobe radeon modeset=1

Ok, I've tried this, the same result: after the last line (inserting radeon
module with modeset set to 1) the screen goes black and nothing. Pressing the
caps lock key hasn't got feedback anymore with the caps lock led either. If
you'd like, I will set up netconsole before trying this, so I can see there is
some kernel log got (but I have the idea that it can be similar that my
netconkern.log what I've already posted).

Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the xorg-driver-ati mailing list