Some observations re: current GIT

Jon Senior jon at
Thu Apr 7 06:38:21 PDT 2011

A while ago Alex produced a patch for me to correct a problem that my
system had detected display modes on an internal display (Bug 31484).
This required me to build from source which I did and everything ran
fine. The patch dated from Nov 10 and having seen many comments of
newer, shinier builds on the mailing list, I decided to upgrade my git
copy and rebuild. I've turned back off nomodeset and radeon.new_pll=0
which previously were the only way of avoiding flicker on the external
display connected to my laptop and everything seems to be behaving
including running two external monitors (One via DVI and one via VGA).

The system is a Thinkpad T60 with a Mobility Radeon X1300 (M52) GPU.
The DVI port comes via a docking station. The two screens are both
1280x1024 resolution and are configured as a single desktop of
2560x1024. I have no xorg.conf file and am relying on to manage
hardware. Running X.Org 1.7.6, video driver ABI: 6.0, radeon / ati
drivers identifying themselves as 6.14.99, but currently compiled from
git as of 07/05/11 at around 14h CEST. Base system is Fedora 12.

I've noticed a couple of things though. Firstly, the system seems to be
running hotter. Although the CPU is the always the first to hit the
alert temperature, both cores are on the same heatsink and the GPU is
now running at around 70°C whereas (from memory) it was nearer to 45°C.
Any heavy graphics or CPU processing now causes overtemperature
warnings. Secondly, I'm getting strange "corruption" of displays which
just looks like the driver confusing where it should be drawing. When I
first start up the system, the main gnome panel at the top of the
screen gets drawn as background colour, like it hasn't been refreshed
properly. Moving the cursor over the menus and icons forces a redraw of
those segments, but I have to hide the panel in order for the whole
thing to refresh. I have a screenshot of this. In a similar manner,
when I use the volume up/down keys on my keyboard, Gnome draws an OSD
to show me this. The OSD appears on one screen, but in the same
location on the other screen I get a box filled with the background
colour. Moving a window over this box causes it to be redrawn.

Finally, the Fedora startup animation seems to be very slow to draw.
As it loads a silhouette of the logo slowly fills with white, then when
full it develops a halo which fades away and becomes the Fedora logo.
The filling up occurs normally, but appears to hang before the start of
the animation and then occurs frame by frame with a delay of up to a
second between frames.

The following appears in dmesg:

[drm:drm_mode_rmfb] *ERROR* tried to remove a fb that we didn't own
[drm:drm_mode_rmfb] *ERROR* tried to remove a fb that we didn't own
[drm:drm_mode_rmfb] *ERROR* tried to remove a fb that we didn't own
[drm:drm_mode_getfb] *ERROR* invalid framebuffer id

I also had other errors before rebooting, but they've not reappeared

Sorry for the mangled mess of issues here. I hope they mean something
to someone. My biggest concern is the temperature issue. I've had
problems already with the T60 overheating, and don't wish the
experience that again.


More information about the xorg-driver-ati mailing list