Many freezes on Xpress 200M

Daniel Klaffenbach danielklaffenbach at
Wed Jan 20 13:29:57 PST 2010

Hi folks!

I've been using the "radeon"-Driver a long time now on my HP nx6125 with a 
Radeon XPress 200M (RS480). A while ago (around Kernel 2.6.25) it worked 
reliably with DRI, 3D and Suspend/Resume. Unfortunately I have experienced a 
lot of complete lock-ups for a long time now (tried several distributions). I 
am always using up-to-date package versions and I did not see this problem go 
away. There are four use-cases and all of them cause problems:

Case 1: Plain 2D (no framebuffer console)
- "radeon"-Driver in Plain 2D mode without any acceleration, no DRI
- Works very well with XAA
- EXA is slow and has issues
- X still crashes sometimes - but restarts automatically (system remains 
usable), see Xorg-0.log [1]
- suspend2ram works after commit e7b26abc3c20fb53bf2cd02404ac5e0654fee18d 
(this commit fixed loads of issues)
- Xorg.conf [2]

Case 2: DRI without framebuffer console
- 3D works well
- EXA works well
- Sometimes screen corruptions appear [3]
- Screen flickering after a few VT switches (system still usable)
- Suspend/Resume does not work (freeze on resume)
- After a while of using X it freezes completely. This happens faster with 
KDE4 than with XFCE (I guess QT is a bit more GFX-intensive). This problem 
appears when doing completely normal things (like scrolling in Firefox or 
Konqueror). No compositing involved! All remote SSH sessions die immediately.

Case 3: DRI with radeonfb
- Same as case #2

Case 4: DRI with KMS
- Same as case #2, although there is no screen flickering after switching VTs
- Wheen booting I get a strange message in dmesg:
[drm:rs400_gart_adjust_size] *ERROR* Forcing to 32M GART size (because of ASIC 
bug ?)
- xorg.conf [4]
- Xorg.0.log [5]
- glxinfo [6]

I also know that I am not the only one suffering from this problem. A friend of 
mine has the same laptop (with a 32bit Sempron) and is having the exact same 
troubles. I did also check my RAM multiple times with memtest - all OK.

What can I do to help you guys solve this problem? I have mesa, xf86-video-
ati, libdrm and xorg-server compiled with debugging information, but the gdb 
output does not seem to be usable.
Right now I am on Gentoo (amd64) with the following packages:
- Kernel: 2.6.33-rc4
- Xorg: 1.7.4
- Mesa: git master
- libdrm: git master
- xf86-video-ati: git master

Thanks for any help in advance!
- Dan

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: This is a digitally signed message part.
Url : 

More information about the xorg-driver-ati mailing list