Bug#565344: [xserver-xorg-video-radeon] Black screen after resume from suspend to disk/RAM

Bruno Kleinert fuddl at debian.org
Thu Jan 14 14:17:06 PST 2010

Package: xserver-xorg-video-radeon
Version: 1:6.12.4-2
Severity: normal

--- Please enter the report below this line. ---

after an upgrade to version 6.12.4-2 from 6.12.3-1 I get nothing but a
mouse cursor and a black screen when I resume the machine from suspend
to disk or RAM.

The mouse cursor and keyboard apperently work fine in the "invisible"
X-session: I can type my password into the invisiable GNOME screensaver
and blindly do things like starting music playback in rhythmbox - so
obviously everything is up and running but not displayed on the screen
(except the mouse cursors).

Switching to a text console seems to work, but it's also invisable. I
can blindly log in and run commands. I tried restarting GDM/X from the
console. When I restart gdm I get back a visible GDM/X and after that
it's again possible to switch back to a visible (!) text console.

I wanted to try out the same sequence of suspend, resume, black screen
(?) with radeonhd, but when I use that driver my machine completely
locks up when suspend is trying to snapshot the system. Sorry, I can't
give any information with that configuration.

Turning off and on compositing in metacity (gconf key:
/apps/metacity/general/compositing_manager) didn't fix anything. Also,
I am not running compiz nor KMS and there is no self-compiled stuff in
use. The only "special" thing is, that I'm using mesa 7.7 from
experimental. But when 6.12.3-1 was installed I had mesa 7.7~rc2-1
packages from experimental installed and suspend/resume worked just
fine with these packages!

Some other stuff about the machine:
fuddl at muhmuh:~$ uname -a
Linux muhmuh 2.6.32-trunk-amd64 #1 SMP Sun Jan 10 22:40:40 UTC 2010 x86_64 GNU/Linux

fuddl at muhmuh:~$ dpkg -s linux-image-2.6.32-trunk-amd64 | grep ^Version
Version: 2.6.32-5

fuddl at muhmuh:~$ dpkg -s firmware-linux-nonfree | grep ^Version
Version: 0.22

fuddl at muhmuh:~$ lspci | grep VGA
02:00.0 VGA compatible controller: ATI Technologies Inc Mobility Radeon HD 3600 Series

Cheers - Fuddl

--- System information. ---
Architecture: amd64
Kernel:       Linux 2.6.32-trunk-amd64

Debian Release: squeeze/sid
  500 unstable        ftp.de.debian.org 
    1 experimental    ftp.de.debian.org 

--- Package information. ---
Depends                       (Version) | Installed
libc6                          (>= 2.7) | 2.10.2-5
libdrm2                      (>= 2.3.1) | 2.4.15-1
libpciaccess0               (>= 0.10.2) | 0.10.9-1
xserver-xorg-core     (>= 2: | 2:1.7.4-1

Package's Recommends field is empty.

Suggests            (Version) | Installed
firmware-linux                | 0.22

Please attach the file: 
to the mail. I'd do it myself if the output wasn't too long to handle.

  Thank you!

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: Dies ist ein digital signierter Nachrichtenteil
Url : http://lists.x.org/archives/xorg-driver-ati/attachments/20100114/71e1cc1f/attachment-0001.pgp 

More information about the xorg-driver-ati mailing list