[Bug 26030] New: Hard reboot after starting Celestia under KMS (Radeon RS780)

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Wed Jan 13 13:21:40 PST 2010


           Summary: Hard reboot after starting Celestia under KMS (Radeon
           Product: xorg
           Version: unspecified
          Platform: x86 (IA32)
        OS/Version: Linux (All)
            Status: NEW
          Severity: blocker
          Priority: highest
         Component: Driver/Radeon
        AssignedTo: xorg-driver-ati at lists.x.org
        ReportedBy: m.krenek at gmail.com
         QAContact: xorg-team at lists.x.org

Created an attachment (id=32618)
 --> (http://bugs.freedesktop.org/attachment.cgi?id=32618)
Kernel log (dmesg)

After starting Celestia under KMS on integrated Radeon RS780 card, I get hard

I have tried looking in realtime (using tail) at /var/log/messages and
/var/log/Xorg.0.log while starting Celestia, but there is nothing before

Celestia starts, first frame is rendered (with Sun), then it looks for about 5
seconds like it is freezed (but other apps works, only Celestia freezes) and
then suddenly black screen and hard reboot.

I have latest Git snapshots of libdrm, mesa and xf86-video-ati from 2010-01-13
and kernel 2.6.33-rc4. I have no such problems under UMS. 3D acceleration under
KMS works (even desktop effects in KDE 4), but there is this hard reboot
problem (I tried it even with disabled desktop effect, but this hard reboot
after starting Celestia is still there).

Configure bugmail: http://bugs.freedesktop.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the xorg-driver-ati mailing list