[Bug 23535] New: Can't out the composite video output on my Macbook Pro

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Wed Aug 26 13:43:29 PDT 2009


           Summary: Can't out the composite video output on my Macbook Pro
           Product: xorg
           Version: 7.3
          Platform: Other
        OS/Version: All
            Status: NEW
          Severity: normal
          Priority: medium
         Component: Driver/Radeon
        AssignedTo: xorg-driver-ati at lists.x.org
        ReportedBy: monnier at iro.umontreal.ca
         QAContact: xorg-team at lists.x.org

Created an attachment (id=28935)
 --> (http://bugs.freedesktop.org/attachment.cgi?id=28935)

I'm trying to connect my Macbook Pro to my old TV (whose sole input is
composite video).  This is done using Apple's "DVI to Video adapter" which has
both an S-video and a composite output.  The video card itself is a Radeon
mobility X1600.

Running the "radeon" driver without any special options, xrandr gives me 2
entries: one for LVDS and one for DVI-0 (which seems to work for all output on
this connector, at least it works as well for a DVI monitor as for a VGA
monitor plugged via Apple's DVI->VGA adapter.  When I plug my "DVI to video"
adapter, "xrandr" tells me that DVI-0 is connected but it has no modes.  I
tried to add modes manually (including some copied from
http://www.nexusuk.org/projects/vga2scart/ which seemed credible) and I do get
some kind of output on my TV, but it's not syncing.

I then tried to enable ATOMTvOut and such options, but all it did was add an
"S-video" entry which didn't seem to help.  It always says it's disconnected. 
It may correctly control the S-video output, actually, but I don't have an
S-video thingy to connect to it to try it out.  In any case, forcing
"ForceTVOut" did not help: xrandr says that the S-video is then connected (of
course) and I can select a mode, but no matter what mode I select, my TV
(connected via the composite, remember) stays desperately black.  With
ATOMTvOut set, the DVI-0 situation stays the same: its connectedness status
reflects the fact that the "DVI to Video" adapter is connected, and if I enable
it with some ntsc-ish mode, I do get some kind of output on my TV, tho it's out
of sync.

I've attached the Xorg.log from one such run.

Configure bugmail: http://bugs.freedesktop.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the xorg-driver-ati mailing list