[Bug 23334] New: 2D Acceleration not working on RV620/HD3470

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Sat Aug 15 16:57:32 PDT 2009


           Summary: 2D Acceleration not working on RV620/HD3470
           Product: xorg
           Version: unspecified
          Platform: x86 (IA32)
        OS/Version: Linux (All)
            Status: NEW
          Severity: normal
          Priority: medium
         Component: Driver/Radeon
        AssignedTo: xorg-driver-ati at lists.x.org
        ReportedBy: maxi at daemonizer.de
         QAContact: xorg-team at lists.x.org

I can't get 2D Acceleration (EXA and XV) to work on my Radeon Card.
I'm running a 2.6.31-rc6 kernel with xserver 1.4.2 (from debian testing) and
radeon driver from today's git.

When I start kdm I only get a black screen with a small horizontal bar
consisting of lots of colored pixels as mouse cursor.
I also tried starting a single xterm. There the xterm is visible, but the
terminal output overlaps when the terminal starts scrolling. Also the
background is black where I think should be the default X pattern.

I tried taking some screen shots but they all look totally different than the
output on my monitor.

When I set 'Option "DRI" "off"' in the xorg.conf everything is as it should be
and I didn't notice any problems (except it's not accelerated).

The card is a Sapphire Radeon HD3470 sitting in the PCIexpress slot in my
desktop PC.

I'll attach some logs and screen shots.

Configure bugmail: http://bugs.freedesktop.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the xorg-driver-ati mailing list