Video out with Radeon 9100LE (Rebadged 8500LE)

Chris Holmes cghol2 at
Mon Oct 13 20:35:41 PDT 2008

I've been trying to get video out to work with the Radeon 9100LE,  
either S-Video or composite, to use my old computer as a media centre.

Distribution: Ubuntu Hardy 8.04
Xorg 7.1 - ATI driver 6.6.8

Xrandr doesn't seem to find the s-video/TV output - output as follows:

Screen 0: minimum 320 x 200, current 1280 x 768, maximum 1920 x 1200
VGA-0 disconnected 1280x768+0+0 (normal left inverted right x axis y  
axis) 0mm x 0mm
DVI-0 disconnected (normal left inverted right x axis y axis)
   1280x768 (0x6d)   80.1MHz
         h: width  1280 start 1344 end 1480 total 1680 skew    0  
clock   47.7KHz
         v: height  768 start  769 end  772 total  795            
clock   60.0Hz

(yes i have nothing connected - i'm accessing the box remotely via VNC  
right now)

I've tried the following options in xfree86
         Option "TVDACLoadDetect" "TRUE"
	Option "TVStandard" "PAL-B"
	Option "ForceTVOut"	"TRUE"
	Option "DefaultConnectorTable" "TRUE"

The best i've got is with the "DefaultConnectorTable" option, which  
gave me a white, blank screen and the following xrandr output.

My next point in call was to try the 6.6.9 drivers. That had the same  

I then tried the 6.6.3 drivers patched with GATOS - with the following  
options this cloned the display at 800x600 resolution with
"Option "TVOutput"	"PAL"
  However, running XMBC crashed the whole computer, and X would crash  
taking down the whole system after the computer was running for 6-15min

xrandr output for 6.3.3 drivers
Screen 0: minimum 400 x 300, current 1920 x 1200, maximum 1920 x 1200
default connected 1920x1200+0+0 0mm x 0mm
    1920x1200      60.0*
    1600x1200      60.0
    1680x1050      60.0
    1400x1050      70.0     60.0
    1280x1024      75.0     60.0
    1440x900       60.0
    1280x960       60.0
    1280x800       60.0
    1152x864       75.0     85.0
    1280x768       60.0
    1152x768       55.0
    1024x768       75.0     70.0     85.0     60.0     87.0
    832x624        75.0
    800x600        75.0     60.0     85.0     72.0     56.0
    640x480        85.0     75.0     73.0     60.0
    720x400        85.0
    640x400        85.0
    640x350        85.0
    512x384        87.0
    416x312        75.0
    400x300        85.0     75.0     72.0     60.0

Attached is the Xorg log files and xorg.conf. Note that no displays  
where connected, hence the strange behavior - but you can see where  
one is loading rage_theatre and the other isn't.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: xorg.conf
Type: application/octet-stream
Size: 3675 bytes
Desc: not available
Url : 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Xorg.6.6.9.log
Type: application/octet-stream
Size: 50156 bytes
Desc: not available
Url : 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Xorg.6.6.3.log
Type: application/octet-stream
Size: 55887 bytes
Desc: not available
Url : 
-------------- next part --------------

Physically the card appears to have a separate rage theatre chip on  
it, rather than the internal rage theatre found on later cards.

It appears that the newer driver doesn't load rage theatre module - is  
there any way to force loading of the theatre driver? The other option  
I thought is a buggy bios on the card, as the documentation suggests  
that xorg-ati reads the output table the card. However the  
'DefaultConnectorTable' option doesn't seem to help.

Any ideas/patches/hacks would be appriciated.

Chris Holmes

More information about the xorg-driver-ati mailing list