Bug#437321: Xpress improvements in upstream ati git

Zack Weinberg zackw at panix.com
Sat Mar 29 18:10:22 PDT 2008

 On Sat, Mar 22, 2008 at 6:31 AM, Brice Goglin
<Brice.Goglin at ens-lyon.org> wrote:
>  All of you reported problems with the ati driver on Xpress chips. Alex
>  Deucher called for testing of the latest ati git on
>  http://www.botchco.com/agd5f/?p=25

With the very latest unstable kernel (linux-image-2.6.24-1-686
package, version 2.6.24-5):

* the git driver by default (no xorg.conf at all) declines to enable
DRI.  It also uses XAA by default, and says that I have to use EXA if
I want Render acceleration.  However, it works just fine.  I'm using
it right now, and will report any problems that arise.

* I tried forcing DRI on with an xorg.conf which reads in its entirety

    Section "Device"
	Identifier	"ATI Technologies Inc RC410 [Radeon Xpress 200M]"
	Driver		"ati"
	BusID		"PCI:1:5:0"
	Option		"DRI" "on"
    #  Option         "AccelMethod" "EXA"

When I restarted gdm after this, it went straight to my desktop
instead of drawing the login screen; it's not supposed to do that.
The desktop was drawn correctly, except for a strip at the very top of
the screen which was garbled.  The mouse pointer appeared and moved
around the screen in response to the touchpad.  However, the rest of
the display was frozen, including things like the gnome-system-monitor
graphs that update without user intervention, and Ctrl-Alt-F1 did not
give me back a text console.  Ctrl-Alt-Backspace *did* kill the X
server, or at least, the mouse pointer stopped moving.  But then the
keyboard was unresponsive; neither blind-typing "reboot" at the text
console with root logged in nor Alt-SysRQ-B did anything.  I was able
to shut down in an orderly fashion by pressing the power button (i.e.
I didn't have to hold it down to force poweroff).

* I also tried forcing EXA on, by uncommenting the AccelMethod line in
the above and commenting out the DRI line.  This works correctly but
is visibly *much* slower than XAA - repaints are delayed when I scroll
windows, text boxes cannot keep up with my typing, and anything that
changes the screen makes the CPU spike.  (I was under the impression
EXA was a failed, abandoned experiment?)

* I did not try enabling both EXA and DRI.


More information about the xorg-driver-ati mailing list