[Bug 9934] New: xserver 1.2.0 fails to start on a Radeon X300

bugzilla-daemon at annarchy.freedesktop.org bugzilla-daemon at annarchy.freedesktop.org
Fri Feb 9 16:56:47 PST 2007


           Summary: xserver 1.2.0 fails to start on a Radeon X300
           Product: xorg
           Version: 7.2
          Platform: Other
        OS/Version: All
            Status: NEW
          Severity: normal
          Priority: medium
         Component: Driver/Radeon
        AssignedTo: xorg-driver-ati at lists.x.org
        ReportedBy: brice.goglin at ens-lyon.org


I am testing the new xserver 1.2.0 package that will enter Debian
experimental soon. It works fine on i945 (even without any config file,
great job :)). But, I can't get X to start on a Radeon X300 box. Both
machines work fine with xserver 1.1.1 (Debian Testing). I am using the
ATI driver 6.6.3. Kernel is 2.6.20 but 2.6.18 does not change anything.

What happens is that the X server does not start at all. The screen
remains black and the server fails to start. I will attach the corresponding
Xorg.0.log and xorg.conf below.
I tried disabling DRI, it still fails. Fortunately, the vesa driver works.

With the ATI driver, I got a "mtrr : no MTRR for c00000000,40000000
found" in dmesg. Looking at /proc/mtrr before and after start X, I see:
    reg00: base=0x00000000 ( 0MB), size= 512MB: write-back, count=1
    reg01: base=0x1ff00000 ( 511MB), size= 1MB: uncachable, count=1
After starting xserver 1.1.1, I get an additional line that I don't
get with 1.2 (maybe because it fails before touching the mtrr):
    reg02: base=0xc0000000 (3072MB), size= 64MB: write-combining, count=1
I can't be sure it is actually related to the bug.

The machine is a Thinkpad T43 with 512MB of RAM. The video card is:
    01:00.0 VGA compatible controller [0300]: ATI Technologies Inc M22
    [Radeon Mobility M300] [1002:5460]

I also tried without any xorg.conf, it fails at the same point.

Any idea?

Brice Goglin

Configure bugmail: http://bugs.freedesktop.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the Xorg-driver-ati mailing list