Bug#397438: Panel stays blank in MergedFB mode

Bryan Stillwell bryan at bokeoa.com
Thu Dec 14 23:08:27 PST 2006


I also ran into this problem with a FireGL X1 (R300-based) on a Debian
unstable machine.  I would like to track down the changeset that
introduced this problem using git-bisect, however, I would like some
guidance on the best method to go about doing this.  So far this is what
I believe the process looks like (please add your opinion to each step
below if you would be so kind):

1. Get the latest code from the git repository.
   a. Do I just use git_xorg?
   b. Do I need xcb too?
   c. Modular or monolith?

2. Remove the current x.org Debian packages to avoid conflicts.

3. Build x.org from the lastest git code.
   a. build.sh ?
   b. jhbuild ?
   c. ./autogen.sh --prefix=/tmp/modular && make && make install ?

4. Test the results to see if the second monitor starts.
   a. startx -- /tmp/modular/bin/Xorg ?

5. If it doesn't work, start using git-bisect.
   a. Find an older changeset that didn't have the problem (I've heard
      6.8.2 worked, but I haven't confirmed.  Any guesses?)
   b. git bisect start
      git bisect bad master
      git bisect good ORIG_CHANGESET

6. Do a 'make clean' here?

7. Repeat steps 3 and 4

8. Run 'git bisect good' if it worked and 'git bisect bad' if it didn't.

9. Repeat steps 6-8 until git tells me which commit is the culprit.


More information about the Xorg-driver-ati mailing list