[PATCH xf86-video-tdfx 0/7] Code cleanup and more chips support

Guillem Jover guillem at hadrons.org
Mon Oct 7 12:11:18 PDT 2013


Hi!

These fix several deprecation warnings, do some code cleanups and
add support for more chips.

Adam, are you still interested in maintaining this?

Thanks,
Guillem

Guillem Jover (7):
  Define local PCI IDs instead of using xf86PciInfo.h
  Rename XSERVER_PCIACCESS to XSERVER_LIBPCIACCESS
  Use new pci_device_(un)map_range functions instead of deprecated ones
  Remove unreachable breaks after return statements
  Use the PCI ID macros instead of hardcoded values
  Unmap MMIO ranges for all chips
  Add more PCI IDs for supported chips

 src/tdfx.h        | 16 ++++++++++++++--
 src/tdfx_accel.c  |  3 ---
 src/tdfx_dri.c    |  1 -
 src/tdfx_driver.c | 55 ++++++++++++++++++++++++++++++++++++-------------------
 4 files changed, 50 insertions(+), 25 deletions(-)

-- 
1.8.4



More information about the xorg-devel mailing list