[PATCH 06/15] Use hardware time where possible

Daniel Stone daniel at fooishbar.org
Tue Jun 14 09:19:10 PDT 2011


Hi,

On Tue, Jun 14, 2011 at 02:25:32PM +1000, Peter Hutterer wrote:
> On Thu, Jun 09, 2011 at 08:57:27PM +0100, Daniel Stone wrote:
> > -    if (newDelay)
> > +    if (newDelay) {
> > +        priv->timer_time = GetTimeInMillis();
> >  	priv->timer = TimerSet(priv->timer, 0, delay, timerFunc, pInfo);
> > +    }
> 
> indentation is busted here.

Grr, fixed.

> > @@ -2190,7 +2187,7 @@ HandleScrolling(SynapticsPrivate *priv, struct SynapticsHwState *hw,
> >      }
> >  
> >      if (priv->autoscroll_yspd) {
> > -	double dtime = (hw->millis - HIST(0).millis) / 1000.0;
> > +	double dtime = (hw->millis - priv->last_scroll_millis) / 1000.0;
> >  	double ddy = para->coasting_friction * dtime;
> >  	priv->autoscroll_y += priv->autoscroll_yspd * dtime;
> >  	delay = MIN(delay, POLL_MS);
> > @@ -2211,7 +2208,7 @@ HandleScrolling(SynapticsPrivate *priv, struct SynapticsHwState *hw,
> >      }
> >  
> >      if (priv->autoscroll_xspd) {
> > -	double dtime = (hw->millis - HIST(0).millis) / 1000.0;
> > +	double dtime = (hw->millis - priv->last_scroll_millis) / 1000.0;
> >  	double ddx = para->coasting_friction * dtime;
> >  	priv->autoscroll_x += priv->autoscroll_xspd * dtime;
> >  	delay = MIN(delay, POLL_MS);
> 
> are these two hunks supposed to be in a different patch?

Argh, yes.

> > @@ -2435,7 +2433,8 @@ repeat_scrollbuttons(const InputInfoPtr pInfo,
> >   * occurs.
> >   */
> >  static int
> > -HandleState(InputInfoPtr pInfo, struct SynapticsHwState *hw)
> > +HandleState(InputInfoPtr pInfo, struct SynapticsHwState *hw, CARD32 now,
> > +            Bool actual)
> 
> "actual"?  maybe add a comment to tell what "actual" stands for.
> also, it doesn't seem to be used anywhere in this patch.

OK, I've broken it out into a separate patch, and picked a better name.

> > +    int timer_time;
> 
> comment missing

Fixed.

Cheers,
Daniel


More information about the xorg-devel mailing list