[PULL updated again] input code cleanup
Peter Hutterer
peter.hutterer at who-t.net
Wed Apr 20 23:08:43 PDT 2011
Updated from the previous one with the ptraccel cleanup patches.
The following changes since commit b3d2164a0361f636bfe77b51456bee9213af4f13:
dri2: Pass out_count by value to update_dri2_drawable_buffers() (2011-04-14 15:21:57 +0300)
are available in the git repository at:
git://people.freedesktop.org/~whot/xserver.git for-keith
Alexandr Shadchin (1):
Simplify auto-detect mouse for WSCONS_SUPPORT
Peter Hutterer (33):
Xi: fix valuator alignment in DeepCopyDeviceClasses (#36119)
Xi: silence valgrind warning. (#36120)
configure: actually require macros 1.13
Xi: return the bad device ID if a passive grab fails with BadDevice.
Xi: fix reply swapping function check for XIPassiveGrabDevice
Xi: exit with error value if CheckGrabValues failed.
Xi: don't swap the status byte in the XIPassiveGrab replies
test: add some XIPassiveGrab protocol testing.
input: remove GetKeyboardValuatorEvents, this is now unnecessary.
test: remove glib dependency
dix: silence compiler warning
xfree86: removed unused "event" variable in xf86PostMotionEventM
dix: fix typo in direction calculation
dix: only use a single return where only one is needed.
dix: improve readbility of DoGetDirection.
dix: improve comment, directions flagged are 45° each
dix: document DoGetDirection's maths
dix: document GetDirection
dix: use single return value in GetDirection
dix: use single return statement in DoGetDirection
dix: CalcTracker only uses the tracker, thus only pass the tracker.
dix: don't pass the index for a tracker around, pass the tracker
dix: add some more documentation to ptraccel code
dix: change ProcessVelocityData2D to BOOL.
dix: rename "res" to "result" for improved readability
dix: Don't use short as bool
dix: rename od, d to prev_delta, delta
dix: use single return statement in ApplySimpleSoftening
dix: split softening and constant deceleration into two functions
dix: reduce the work done by ApplySoftening
dix: reduce scope of tmp and mult.
dix: rename a bunch of variables to be more self-explanatory
dix: improve control flow in QueryTrackers
Xext/xtest.c | 2 +-
Xi/exevents.c | 11 +-
Xi/extinit.c | 2 +-
Xi/xichangehierarchy.c | 2 +
Xi/xipassivegrab.c | 16 +-
configure.ac | 4 +-
dix/devices.c | 49 +++-
dix/getevents.c | 21 +-
dix/ptrveloc.c | 292 ++++++++++-------
dix/resource.c | 2 +-
hw/dmx/input/dmxevents.c | 6 +-
hw/kdrive/src/kinput.c | 4 +-
hw/xfree86/common/xf86Configure.c | 13 +-
hw/xfree86/common/xf86Events.c | 2 +-
hw/xfree86/common/xf86Xinput.c | 15 +-
hw/xnest/Events.c | 2 +-
hw/xquartz/darwinEvents.c | 2 +-
hw/xwin/winkeybd.c | 2 +-
include/input.h | 11 +-
include/inputstr.h | 2 +-
include/ptrveloc.h | 2 +-
test/Makefile.am | 6 +-
test/input.c | 523 ++++++++++++++++---------------
test/list.c | 57 ++--
test/xi2/Makefile.am | 10 +-
test/xi2/protocol-common.c | 5 +-
test/xi2/protocol-common.h | 11 +-
test/xi2/protocol-eventconvert.c | 172 +++++------
test/xi2/protocol-xigetclientpointer.c | 31 +-
test/xi2/protocol-xigetselectedevents.c | 28 +-
test/xi2/protocol-xipassivegrabdevice.c | 234 ++++++++++++++
test/xi2/protocol-xiquerydevice.c | 98 +++---
test/xi2/protocol-xiquerypointer.c | 38 +--
test/xi2/protocol-xiqueryversion.c | 28 +-
test/xi2/protocol-xiselectevents.c | 24 +-
test/xi2/protocol-xisetclientpointer.c | 32 +-
test/xi2/protocol-xiwarppointer.c | 24 +-
test/xkb.c | 76 +++---
test/xtest.c | 39 +--
39 files changed, 1078 insertions(+), 820 deletions(-)
create mode 100644 test/xi2/protocol-xipassivegrabdevice.c
More information about the xorg-devel
mailing list