[PULL] keyboard and button bit flag handling, miPointer deduplication
Peter Hutterer
peter.hutterer at who-t.net
Tue Jul 6 20:41:21 PDT 2010
subject says it all, kinda. only patch 3 has functional changes, the others
are cleanup.
The following changes since commit 9f0b193acdc29e491b6245390cf9f53b5222e6d3:
miDbe window priv priv is pre-allocated, don't use dixSetPrivate (bug 28639) (2010-07-02 12:30:24 -0400)
are available in the git repository at:
git://people.freedesktop.org/~whot/xserver.git for-keith
Peter Hutterer (7):
mi: De-duplicate some code in mipointer.c
mi: rename miPointerMoved to miPointerMoveNoEvent.
dix: treat flags as flags, not as value in key_is_down.
Xi: use set_key_up/down instead of manual bit handling.
dix: use BitIsOn/SetBit/ClearBit macros for set_key_down helpers.
dix: add aux. functions for button_is_down, set_button_down, set_button_up.
dix: purge leftover manual key down bit setting.
Xi/exevents.c | 27 +++++++++------------
dix/events.c | 12 ++-------
dix/getevents.c | 49 ++++++++++++++++++++++++++++++++-------
hw/dmx/input/atKeynames.h | 2 -
hw/kdrive/ephyr/ephyr.c | 8 +-----
hw/xfree86/common/xf86Events.c | 4 +--
hw/xnest/Keyboard.c | 8 +-----
hw/xwin/winkeynames.h | 1 -
include/input.h | 9 +++++-
mi/mipointer.c | 24 ++++---------------
10 files changed, 70 insertions(+), 74 deletions(-)
More information about the xorg-devel
mailing list