build problem with --enable-install-libxf86config

Simon Thum simon.thum at
Thu Dec 16 23:58:56 PST 2010

On 12/16/2010 10:49 PM, Alan Coopersmith wrote:
> Simon Thum wrote:
>> On 12/16/2010 10:09 PM, Alan Coopersmith wrote:
>>> Simon Thum wrote:
>>>> Hi List,
>>>> on my gentoo box I have a server build which fails (using the live xorg
>>>> ebuilds). The ebuild invokes:
>>>> ./configure (lots) --enable-install-libxf86config (lots more)
>>>> My (separate) dev builds didn't fail. So I applied the above command
>>>> line to my dev tree and, viola, the exact same error occurred:
>>>> make[4]: Entering directory `/usr/src/xorg/tree/xserver/hw/xfree86/parser'
>>>> make[4]: *** No rule to make target `/os/xprintf.c', needed by
>>>> `libxf86config_a-xprintf.o'.  Stop.
>>> Oh!  Is that what is about?
>>> I didn't realize that was a mistake in my asprintf patches - sorry.
>>> Does fixing the capitalization in as the bug suggests solve it?
>> Nope. I did distclean, configure & make in between - should that not
>> suffice please try for yourself.
> You would have to run automake or to regenerate the from
>   I'll try later when I get some time to poke at it.
Ah - I just tried again with autogen, the fix is correct.



More information about the xorg-devel mailing list