intel-gen4asm: Changes to 'master'

Haihao Xiang haihao at kemper.freedesktop.org
Wed Sep 26 23:37:43 PDT 2012


 src/brw_structs.h     |   10 +--
 src/gen4asm.h         |    1 
 src/gram.y            |   95 ++++++++++++++---------------
 src/main.c            |  163 ++++++++++++++++++++++++++------------------------
 test/Makefile.am      |    7 +-
 test/declare.expected |    3 
 test/declare.g4a      |    4 +
 test/run-test.sh      |   90 ++++++++++++++++++++++++---
 8 files changed, 232 insertions(+), 141 deletions(-)

New commits:
commit 4d8bc5d8551b16e0ac7fd8e5b47aac4c33e424fc
Author: Homer Hsing <homer.xing at intel.com>
Date:   Thu Sep 20 13:09:15 2012 +0800

    Fix field length of JIP for one-offset-branch in Gen6
    
    Such JIP has 25 bits length in Gen6.

commit 0f6943ed72116201edb2f51f760784a92a9be2ed
Author: Homer Hsing <homer.xing at intel.com>
Date:   Wed Sep 19 09:34:58 2012 +0800

    Automatically run all test cases.
    
    In the past test/run-test.sh run only one test case per call.
    This patch let it automatically run all test cases.

commit 5312be2ea55ee3acfd7453b71d3f7e15297eaf1a
Author: Homer Hsing <homer.xing at intel.com>
Date:   Tue Sep 18 16:44:45 2012 +0800

    Fix missing environment variables problem in test/run-test.sh
    
    Currently test/run-test.sh cannot get the value of ${srcdir} and
    ${top_builddir}. Thus we cannot run any test case. This patch uses
    $0 to get the absolute path of run-test.sh. Now test cases work.

commit a4cc1c4ed5d7c9ff90b4f14aae09d2792bcbb5e8
Author: Homer Hsing <homer.xing at intel.com>
Date:   Tue Sep 18 16:32:39 2012 +0800

    Add a generic hash table algorithm. Reuse for declared_reg_table and label_table in the future.
    
    Rewrite find_register() and insert_register(). The hash table code
    has been extracted. We may use those code for label table in the future.

commit 00079e4c041e99f8c686ae2d138c8376e30e7eb3
Author: Homer Hsing <homer.xing at intel.com>
Date:   Tue Sep 18 16:28:27 2012 +0800

    Add a test case for ".declare" pragma

commit 235dbfe81c20df2c82f1a0d4d931320b5f669245
Author: Homer Hsing <homer.xing at intel.com>
Date:   Tue Sep 18 13:57:20 2012 +0800

    Rename brw_instruction.bits3.if_else to branch
    
    Because that field will be used for all branch instructions

commit 2cf920f234608f951198b9bec0281de4068bcebe
Author: Homer Hsing <homer.xing at intel.com>
Date:   Tue Sep 18 13:47:22 2012 +0800

    According to BSPEC, put PLN & BFI1 to binaryop, put SUBB to binaryaccop
    
    bspec: BFI1 should not access accumulator. PLN should not use accumulator
    as source.
    future work in gram.y: show warning if acc is used as dest for
    ADDC/SUBB/CMP/CMPN/SHL/BFI1.

commit 8c59c185c22ec52a27de4324882a286df116d8d1
Author: Homer Hsing <homer.xing at intel.com>
Date:   Tue Sep 18 13:25:53 2012 +0800

    Explain the difference between binaryinstruction and binaryaccinstruction
    
    Developers may add new instructions in wrong place in the future
    if they don't know the difference between binaryinstruction and
    binaryaccinstruction.

commit 6608fc4de927d8a940625d07522f805c47552a21
Author: Homer Hsing <homer.xing at intel.com>
Date:   Tue Sep 18 13:12:50 2012 +0800

    Renaming according to BSPEC: jump_count -> JIP; pop_count -> UIP.
    
    Since bspec SNB+, jump_count and pop_count is renamed to JIP and uIP.

commit e0b2236b0e497467d9ec0636e0e2dcdaeb7ea1b7
Author: Homer Hsing <homer.xing at intel.com>
Date:   Mon Sep 17 16:11:49 2012 +0800

    Use bits3.if_else.jump_count instead of bits3.ud for readability

commit 95a4762a71a23d0f016f62ff5f0105eb815e78f1
Author: Homer Hsing <homer.xing at intel.com>
Date:   Mon Sep 17 16:01:16 2012 +0800

    Pad NOP instructions instead of the ILLEGAL instruction for entry
    
    If a label is an entry, the assembler will pad empty instruction
    before the label until offset % 4 == 0. In the past, the ILLEGAL
    instructions are padded. It may raise exceptions. We use the NOP
    instructions instead.

commit 7aaad71a65473c4d58227c25867ad00d7793740c
Author: Homer Hsing <homer.xing at intel.com>
Date:   Mon Sep 17 13:34:38 2012 +0800

    Merge same if branches in declare_pragma section in gram.y

commit 1ef4bcb42107bb7e6227a9620e2359ada8c91baf
Author: Homer Hsing <homer.xing at intel.com>
Date:   Fri Sep 14 15:27:19 2012 +0800

    Reduce memory cost in entry_table
    
    Original code double entry table space if there is no space. It may
    waste 50% memory of the entry table. Now we use a link list to store
    entry items.

commit 9d654318d7f4cbee3ca59c2eeb66bfcf9e57d02a
Author: Homer Hsing <homer.xing at intel.com>
Date:   Fri Sep 14 13:40:08 2012 +0800

    Make the entry point padding code logic looks nicer

commit 182a52cb932ecb83f5f9ef9b164b502f7f9b5cee
Author: Homer Hsing <homer.xing at intel.com>
Date:   Fri Sep 14 10:50:09 2012 +0800

    Fix a typo in src/main.c: "in unit of type" -> "in unit of byte"

commit dafec4c3fbb9ef192e8a92a1bc5388ce4bd31fd0
Author: Homer Hsing <homer.xing at intel.com>
Date:   Fri Sep 14 10:06:39 2012 +0800

    Reduce hash value collision probability in src/main.c
    
    Original code use "hash_value = *name++", which may produce
    hash value collision for word permutations like "abc", "bac" and "cba".

commit 0cab8e3447c298e8bb6c457964f6b3c0c2665c5a
Author: Homer Hsing <homer.xing at intel.com>
Date:   Fri Sep 14 10:02:53 2012 +0800

    Move program_defaults init statement into variable declaration
    
    In original code, the init value for "program_defaults.register_type"
    is put inside main(), which may be hard to maintain.

commit 8f9847971416e5658de683792c5ce7fe0c38cf27
Author: Homer Hsing <homer.xing at intel.com>
Date:   Fri Sep 14 09:42:30 2012 +0800

    Better comment text. Change "c like" to "C style" in main.c

commit 06d9c81679ea6ca27b23e068cb58aaea553bf211
Author: Homer Hsing <homer.xing at intel.com>
Date:   Fri Sep 14 09:34:58 2012 +0800

    Replace bzero by memset.
    
    bzero has been removed from POSIX.1-2008. Should use memset instead.



More information about the xorg-commit mailing list