inputproto: Changes to 'master'

Peter Hutterer whot at kemper.freedesktop.org
Mon Jun 6 16:28:38 PDT 2011


 XI2.h |   23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

New commits:
commit 2cd2adb7a454072954704e1a215df49ce9dac410
Author: Peter Hutterer <peter.hutterer at who-t.net>
Date:   Fri Jun 3 15:56:21 2011 +1000

    Provide convenience defines for owner_events.
    
    No functional effect, just to improve readability of code.
    
    It's not obvious what "True" or "False" stands for in a function with 11
    arguments. Compare
        XIGrabButton(dpy, deviceid, button, grab_window, cursor,
                     GrabModeAsync, GrabModeSync, True,
                     event_mask, num_modifiers, &modifiers);
    
    vs.
    
    XIGrabButton(dpy, deviceid, button, grab_window, cursor,
                 GrabModeAsync, GrabModeSync, XIOwnerEvents,
                 event_mask, num_modifiers, &modifiers);
    
    Signed-off-by: Peter Hutterer <peter.hutterer at who-t.net>
    Reviewed-by: Daniel Stone <daniel at fooishbar.org>

commit bef7648827a0696debdd629472a45508a30144b1
Author: Peter Hutterer <peter.hutterer at who-t.net>
Date:   Fri Jun 3 15:13:12 2011 +1000

    Add XI2-specific defines for grab and property requests
    
    XI 2.0 headers forced clients to mix XI2 specific constants with defines for
    core input. Most notable here are the grab code which required GrabModeAsync
    or GrabModeSync from core, but _not_ AnyModifier (XIAnymodifier !=
    AnyModifier). This is a hard-to-debug cause for bugs.
    
    Add defines for grab modes, grab return codes and property modes as well as
    a define for the AnyPropertyType. These defines are identical to the ones
    defined in core but stop the use of input-related defines from either core
    or XI 1.x.
    
    Clients must use the core defines None and CurrentTime where applicable.
    
    Signed-off-by: Peter Hutterer <peter.hutterer at who-t.net>
    Reviewed-by: Daniel Stone <daniel at fooishbar.org>



More information about the xorg-commit mailing list