xf86-input-evdev: Changes to 'refs/tags/xf86-input-evdev-2.0.99.1'

Peter Hutterer whot at kemper.freedesktop.org
Thu Oct 16 18:37:11 PDT 2008


Tag 'xf86-input-evdev-2.0.99.1' created by Peter Hutterer <peter.hutterer at redhat.com> at 2008-10-14 07:52 -0700

evdev 2.0.99.1
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQBI9EGX3RuwF+7s5c4RAi+yAKCQWXJphCk0AElEqR/jb0w36L937QCfbeCz
/oHSwG7RRFXtxnKQyipkBgg=
=vdKv
-----END PGP SIGNATURE-----

Changes since xf86-input-evdev-2.0.0:
Adam Jackson (1):
      Print a warning if a keycode exceeds the range accepted by the server.

Ander Conselvan de Oliveira (1):
      Mice with a lot of buttons (e.g. Logitech MX1000) generate button events greater than BTN_TASK.

Chris Salch (4):
      Adding a function to map button events to button numbers.
      Adding mouse wheel emulation code.
      Filter wheel events before middle mouse button emulation.
      Adding in DragLockButtons functionality.

Dan Nicholson (2):
      Add timeout support for mouse wheel emulation
      Add wheel timeout property support

Daniel Stone (1):
      Force rules, not model, to be evdev

Julien Cristau (4):
      Fill up the version info
      Print the device name when we get a read error
      Actually close the fd on DEVICE_CLOSE (bug#16948)
      Set pInfo->fd to -1 on DEVICE_CLOSE

Keith Packard (1):
      Enable middle button emulation at DEVICE_ON instead of DEVICE_INIT.

Michel Dänzer (1):
      xf86-input-evdev: Fix EVIOCGBIT ioctl usage on big endian platforms.

Peter Hutterer (55):
      No need to finalize MB emulation after EvdevProbe anymore.
      Bump to 2.0.99.
      Count buttons at probe and print to log.
      Remove EvdevConvert, nobody calls it now anyway.
      Remove stale comments.
      Update COPYING with the correct copyright info.
      Remove static ChangeLog, autogenerate as part of make dist.
      Clean out configure.ac
      Add support for device properties, currently MB emulation and timeout.
      Add .gitignore file.
      Don't enable the device if the grab failed with ENODEV.
      Guard property changes against ABI_XINPUT < 3.
      Add support for ButtonMapping option.
      Expose wheel emulation through device properties.
      Add EVDEV_MAXBUTTONS instead of checking against 32.
      Simplify the property handler registration.
      Don't grab devices unless specified through the config options.
      Revert "Don't grab devices unless specified through the config options."
      Add property support for drag lock.
      Init all emulateWheel values, even if EmulateWheel is disabled.
      Wheel emulation: initial values must be char.
      Shut up "unused variable" compiler warnings.
      Use HAVE_PROPERTIES define instead of GET_ABI_MAJOR for property compilation.
      Attempt to re-open devices on read errors.
      Don't require randrproto.
      draglock: Shut up compiler warning.
      Use new property API (no ConfigureDP, less args to ChangeDP)
      Add evdev-properties.h file with #defines for all property names.
      Cleanup: "valid_vals" should be "vals" now.
      Register property handlers directly, instead of abstracting them.
      Move misplaced #endif
      Change DragLock atom name - prepend with Evdev.
      Remove useless initialization of rc.
      Close fd on DEVICE_OFF. (LP #276887)
      Install xorg-evdev.pc for clients who need evdev-properties.h
      Add property support for axis inversion.
      Stricter value checking for property changes.
      Fix up bad return code in draglock property handler.
      Add checkonly handling to property handlers.
      Janitor: purge unused headers, reshuffle for readability, fix whitespace errors.
      Remove parsing of ScreenNumber option.
      Remove "Path" option.
      Document InvertX/Y options.
      Document properties in man page.
      Add property support for ReopenAttempts option.
      Janitor: clean up xf86Msg use, might as well use X_CONFIG directly.
      Clean up program flow - don't call PreInit for "modules" on DEVICE_INIT.
      Register property handler from within the modules, not the main evdev file.
      Rename DragLockInit to DragLockPreInit, remove superfluous "return".
      Tidy up evdev.h
      Don't include the client-side header anymore. xkbstr.h is server SDK.
      8-bit properties should use 8-bit storage types...
      Don't init draglock, etc. if we don't have the required capabilities.
      Fix "Device reopened after N attempts" message.
      evdev 2.1 RC 1.

Simon Munton (1):
      Close file descriptor if EvdevProbe fails.

Søren Hauberg (1):
      Add support for axis inversion.

---
 .gitignore                 |   27 +
 COPYING                    |   99 ++++++
 ChangeLog                  |   47 ---
 Makefile.am                |   17 +
 configure.ac               |   28 -
 include/Makefile.am        |    2 
 include/evdev-properties.h |   61 ++++
 man/Makefile.am            |    2 
 man/evdev.man              |  136 ++++++++-
 src/Makefile.am            |    7 
 src/draglock.c             |  318 +++++++++++++++++++++
 src/emuMB.c                |   93 +++++-
 src/emuWheel.c             |  466 +++++++++++++++++++++++++++++++
 src/evdev.c                |  669 ++++++++++++++++++++++++++++++++++++---------
 src/evdev.h                |   72 ++++
 xorg-evdev.pc.in           |    6 
 16 files changed, 1820 insertions(+), 230 deletions(-)
---


More information about the xorg-commit mailing list