compiz: Changes to 'refs/tags/compiz-0.7.4'

Dennis Kasprzyk onestone at kemper.freedesktop.org
Thu Apr 3 08:22:42 PDT 2008


Tag 'compiz-0.7.4' created by Dennis kasprzyk <onestone at opencompositing.org> at 2008-04-03 16:15 -0700

compiz 0.7.4 release
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.4-svn0 (GNU/Linux)

iD8DBQBH9PSst48tbid8NDcRAm3IAJwKdrlNKQB/+f5LXdYYu9yw5nRSgACfchTN
ZoOEVM2PoTK9kBr9aiNKCA4=
=X8hp
-----END PGP SIGNATURE-----

Changes since compiz-0.7.2:
C-F Language team (2):
      compiz translation updates
      translation updates

Danny Baumann (49):
      Annotate draw is a dbus only action, reflect that in the metadata.
      Merge branch 'master' of git+ssh://maniac@git.freedesktop.org/git/xorg/app/compiz
      Generalize session event functions to have only one event function instead of four.
      Add a sessionInit and a sessionFini callback function.
      Bump ABIVERSION.
      Merge branch 'master' of git+ssh://maniac@git.freedesktop.org/git/xorg/app/compiz
      Minor coding style fix.
      Make outputDeviceForGeometry behave smarter when dealing with overlapping outputs.
      Clamp point/geometry to compare to visible screen area.
      Reduce duplicated code by reusing the outputDeviceForGeometry function to implement outputDeviceForPoint. For this, treat a point x,y just as a 1x1 sized rectangle which has its upper left corner at x,y.
      Add another overlapping output handling mode "Smart". "Smart" basically is the old "Prefer larger" mode, selecting the output most part of the rectangle is on. "Prefer larger" and "Prefer smaller" only look for the rectangle center to determine the output.
      Remove sessionInit and sessionFini wrappable functions.
      Selected selected window when terminating scale instead of the last active window.
      When a position match is given for a window, constrain the positiong to the output for the geometry given in the match instead of the current output.
      Make activateWindow function wrappable so plugins can react on window activation.
      Switch viewports on window activation, not on focus change.
      The largedesktop plugins are responsible for switching viewports when a window is activated.
      Add option for selecting the amount of focus stealing prevention.
      Added screen edge trigger delay settings.
      Also use screen edge delays for DnD actions.
      Add nodelay hint to flip edges.
      Bump ABIVERSION.
      Also set w->managed on MapNotify event.
      Improve comment and variable name.
      Use passed geometry for constraining min/max size rather than server geometry.
      Merge branch 'master' of git+ssh://maniac@git.freedesktop.org/git/xorg/app/compiz
      Don't send sync requests from reconfigureXWindow function.
      Adjust ConfigureRequest geometry for decoration size. Reference: https://bugs.freedesktop.org/show_bug.cgi?id=13589
      Send sync request when changing window size due to updating window attributes.
      Don't send out sync request when nothing changed.
      Don't set mask in addWindowSizeChanges if the new geometry matches the old geometry.
      Update saved window geometry when adding/removing decorations.
      Recalculate window type before updating window state.
      Always recalculate window type and actions when changing window state.
      Don't allow minimization of windows that don't have the minimize action set and reduce code duplication.
      Remove all clones on unload.
      Fix a number of damage issues.
      Merge branch 'master' of git+ssh://maniac@git.freedesktop.org/git/xorg/app/compiz
      Correctly unwrap on unload.
      If we couldn't get the timestamp for the window, try to get at least the timestamp of its transient parent for determining if the window should get focus or not.
      Allow minimization for all normal type windows.
      Recalculate window actions on frame size and transient status changes as the available actions depend on both.
      Also maximize too-big-for-workarea windows if their placement was skipped.
      Avoid unnecessarily unloading plugins if the new plugin list does not contain the core plugin.
      Merge branch 'master' of git+ssh://maniac@git.freedesktop.org/git/xorg/app/compiz
      Allow shading for all kinds of decorated windows.
      Allow key and button bindings being used interchangably in move and resize plugins.
      Remove some dead code.
      Update German translation.

Dennis Kasprzyk (26):
      Post release version increment.
      Added an option to control the selection of an output device, if the output regions overlap in the given point (xrandr 1.2 clone mode).
      Initialize output size correctly.
      Unredirect top most fullscreen window also if it only covers one output device. This also fixes unredirecting of applications/games that change the display resolution.
      Set and use w->texCoordSize;
      Added vertexStride window variable.
      Use also "z" component in the vertex array, to ensure that plugins like blur that use the vertex array for calculations, can always work with all components.
      Use core changes in wobbly.
      Apply core changes to blur.
      Use minimum and maximum "z" component for vertex projection.
      Try to start decorator in initScreen because a value for DECOR_DISPLAY_OPTION_COMMAND might been already set in the xml metadata.
      Enable "Drag and Drop" action state for rotate flip edges.
      Typo.
      Calculate a generic rotation progress value and use it to calculate the cube zoom out.
      Pass cube progress in getRotation function.
      Use cube progress to calculate cube transparency.
      Moved multi output handling from rotate to cube to make it also work with inactive transparency.
      Bump cube ABI.
      Provide glMultiTexCoord2f in screen struct.
      Make as many as possible texture fetches independent in first pass of gaussian blur.
      Make as many as possible texture fetches independent in second pass of gaussian blur.
      Use constants in the shader code instead of program parameters.
      Added option for the independent texture fetch feature in blur.
      Reorder blur texture fetches, to fetch all pixels in one indirection step on radeon cards.
      Bump core ABI.
      Add NEWS entry and bump version for 0.7.4 release.

Erkin Bahceci (1):
      Texture compression for image textures.

Jigish Gohil (1):
      remove wrong be translation

---
 NEWS                     |   22 
 configure.ac             |    4 
 include/compiz-core.h    |  103 +
 include/compiz-cube.h    |   14 
 metadata/annotate.xml.in |    3 
 metadata/blur.xml.in     |    5 
 metadata/core.xml.in     |   54 
 metadata/cube.xml.in     |   10 
 metadata/rotate.xml.in   |    4 
 plugins/annotate.c       |    2 
 plugins/blur.c           |  475 ++++++-
 plugins/clone.c          |   17 
 plugins/cube.c           |   75 -
 plugins/decoration.c     |    9 
 plugins/move.c           |   44 
 plugins/place.c          |   47 
 plugins/plane.c          |   38 
 plugins/resize.c         |   32 
 plugins/rotate.c         |  185 +--
 plugins/scale.c          |   42 
 plugins/wobbly.c         |   15 
 po/af.po                 |  420 ++++--
 po/ar.po                 |  411 ++++--
 po/be.po                 | 2826 -----------------------------------------------
 po/bg.po                 |  442 ++++---
 po/bn.po                 |  442 ++++---
 po/bn_IN.po              |  488 ++++----
 po/bs.po                 |  428 ++++---
 po/ca.po                 |  431 ++++---
 po/cs.po                 |  433 ++++---
 po/cy.po                 |  427 ++++---
 po/da.po                 |  431 ++++---
 po/de.po                 |  718 ++++++-----
 po/el.po                 |  434 ++++---
 po/en_GB.po              |  437 ++++---
 po/en_US.po              |  420 ++++--
 po/es.po                 |  439 ++++---
 po/et.po                 |  438 ++++---
 po/eu.po                 |  460 ++++---
 po/fi.po                 |  436 ++++---
 po/fr.po                 |  437 ++++---
 po/gl.po                 |  449 ++++---
 po/gu.po                 |  434 ++++---
 po/he.po                 |  443 ++++---
 po/hi.po                 |  440 ++++---
 po/hr.po                 |  440 ++++---
 po/hu.po                 |  436 ++++---
 po/id.po                 |  428 ++++---
 po/it.po                 |  440 ++++---
 po/ja.po                 |  492 +++++---
 po/ka.po                 |  411 ++++--
 po/km.po                 |  442 ++++---
 po/ko.po                 |  434 ++++---
 po/lo.po                 |  411 ++++--
 po/lt.po                 |  442 ++++---
 po/mk.po                 |  412 ++++--
 po/mr.po                 |  425 ++++---
 po/nb.po                 |  436 ++++---
 po/nl.po                 |  438 ++++---
 po/or.po                 |  434 ++++---
 po/pa.po                 |  447 ++++---
 po/pl.po                 |  675 ++++++-----
 po/pt.po                 |  443 ++++---
 po/pt_BR.po              |  434 ++++---
 po/ro.po                 |  432 ++++---
 po/ru.po                 |  443 ++++---
 po/sk.po                 |  441 ++++---
 po/sl.po                 |  444 ++++---
 po/sr.po                 |  448 ++++---
 po/sv.po                 |  434 ++++---
 po/ta.po                 |  411 ++++--
 po/tr.po                 |  445 ++++---
 po/uk.po                 |  481 +++++--
 po/vi.po                 |  411 ++++--
 po/xh.po                 |  420 ++++--
 po/zh_CN.po              |  437 ++++---
 po/zh_TW.po              |  436 ++++---
 po/zu.po                 |  420 ++++--
 src/core.c               |    5 
 src/display.c            |   25 
 src/event.c              |  164 ++
 src/metadata.c           |   28 
 src/paint.c              |   51 
 src/screen.c             |  201 ++-
 src/session.c            |   85 -
 src/texture.c            |    8 
 src/window.c             |  194 ++-
 87 files changed, 17035 insertions(+), 12713 deletions(-)
---


More information about the xorg-commit mailing list