[ANNOUNCE] xorg-server 1.11.99.2
Keith Packard
keithp at keithp.com
Sat Dec 17 17:39:50 PST 2011
Here's the second 1.12 snapshot release. Most of this is cleanups from
alanc and preparatory work for the Xi 2.2 integration. It looks like
that piece is nearly ready to merge; Peter has put the changes out for
review. When that's finished, the merge window will be closed.
There are a couple of patch sets which are outstanding today:
* Gaetan's changes to the server C flags. I'd like to see some
discussion about these as I don't quite get the rational.
* Jamey's GC clipping changes. These have been reviewed and are
pretty much ready for merging. I looked over them and offered
a few comments, but I don't see any reason they can't get merged
this week.
One week to go...
Adam Jackson (1):
fbdevhw: iterate over all modes that match a mode. (v3)
Alan Coopersmith (69):
Fix Xdmx build on Linux to work with strlcpy changes
Don't fallback to wsfb or fbdev on Solaris
Don't require ld -wrap for tests that don't need it
Enable memory checking during unit testing
Remove a couple Error() instances left behind by 09dbfcb0ad7b6c8
Fix Sun compiler check that got turned around
Add fallback implementation of strndup()
Convert some malloc + strncpy pairs into strndup calls
Convert AllocXTestDevice to use asprintf
Convert strncpy/strncat to strlcpy/strlcat
matchDriverFromFiles: use one snprintf instead of strncpy/cat series
Convert dmxSetDefaultFontPath to use strdup instead of malloc+strncpy
Convert DetermineClientCmd to use strdup instead of malloc+strncpy
Convert ProcRenderQueryFilters to use memcpy instead of strncpy
Make XIGetKnownProperty take a const char * argument
Remove unnecessary variable rtrn in XkbKeysymText
AuthAudit: clean up string handling calls
LogVMessageVerb: Fix const mismatch warning
Convert glx/single2.c:DoGetString() to use asprintf()
Remove bad code from DoShowOptions (Xorg -showopts handler)
Move DoShowOptions to xf86Configure.c, delete xf86ShowOpts.c
Remove xf86FormatPciBusNumber from API, inline the one place its used
Convert a bunch of sprintf to snprintf calls
Reduce unnecessary string copying in xkbtext routines
Mark arguments to fopen/popen/system wrappers as const char *
Mark XKB char * as const to clean up gcc -Wwrite-strings warnings
sun_agp: cast key to uintptr_t before casting to (int *)
Remove redundant redeclarations of functions in the same header file
Fix gcc -Wwrite-strings warnings in XkbGetRulesDflts
Fix gcc -Wwrite-strings warnings in various extensions
FindModule: stop copying const char *dirname to char *dirpath
Fix gcc -Wwrite-strings warnings in xf86 ddx
Fix gcc -Wwrite-strings warnings in xf86Modes code
Limit the number of screens Xvfb will attempt to allocate memory for
Disable building of tests requiring DDX functions when Xorg is not built
Remove unused function checks from configure.ac & include/*.h.in
Move to autoconf standard function name checks & defines
Fix gcc warnings about redundant declarations of fallback functions
LoaderOpen returns either a valid pointer or NULL, so don't check for < 0
Fix builds of Xnest & Xephyr with Solaris Studio compilers
Change disable_clientpointer return type to void
xf86RegisterRootWindowProperty is confused about xnfcalloc
Even more correctly free config file names
CheckForEmptyMask does not need to declare int n twice
constify strings in resource name registry
xres.c: Preserve constness of string returned by LookupResourceName
os/access.c: replace acmp & acopy macros with memcmp & memcpy calls
Constify string for authorization protocol names
Constify the reason string throughout the authorization check framework
OsInit: store "/dev/null" in a const char *
WriteToClient: preserve constness of buf while extracting length value
LockServer: store path to LOCKDIR literal string in a const char *
xdmcp.c: fix three small const warnings
CompareISOLatin1Lowered: constify arguments
x86emu: constify debug strings
DoShowOptions: preserve constness of options list as we walk it
Convert KdDoSwitchCmd to use asprintf instead of malloc/strcat/etc.
KdParseFindNext: Constify delim argument
XkbFindSrvLedInfo: remove extraneous name-clashing sli variable
_XkbFilterDeviceBtn: move variable declarations to match usage scope
Remove duplicate declaration of xf86ValidateModesFlags in xf86Modes.h
Remove duplicate declarations of KdAdd*Driver in kdrive.h
xf86Priv.h: Add some noreturn attributes suggested by gcc
Add some printf format attributes suggested by gcc
xf86 parser: convert Error to a varargs macro to clear gcc format warnings
Include client name if available in PrintDeviceGrabInfo
Fix deconstifying cast warning in xi2_get_type
Use const cast in BitIsOn macro to avoid angering gcc
verify_internal_event: preserve constness of data pointer
Antoine Martin (1):
xserver: check for elevated privileges not uid=0
Chase Douglas (3):
include: Add an InputLevel enum
dix: Move grab check and activation logic to CheckPassiveGrab()
dix: Split ActivatePassiveGrab() from CheckPassiveGrab()
Dave Airlie (6):
xext: don't free uninitialised pointer when malloc fails. (v2)
Xi: avoid overrun of callback array.
xaa: avoid possible freed pointer reuse in epilogue
xv: test correct number of requests. (v2)
hal: free tmp_val in one missing case
kdrive: drop screen crossing code.
Gaetan Nadon (6):
docs: spell "X Server Version" consistently in titles. Add where missing.
config: conftest needs an include directive to locate X11/Xfuncproto.h
autoconf: remove redundant AC_PROG_MAKE_SET
autoconf: the minimum required level for autoconf is 2.60
test: update .gitignore with xfree86 and sort alphabetically
dmx: fix distcheck failure, missing compsize.h in Makefile.am
Jeremy Huddleston (2):
dmx: Build fix for -Werror=implicit-function-declaration
dmx: Build fix for -Werror=implicit-function-declaration on linux
Julien Cristau (1):
Fix ShmPutImage for XYBitmap
Keith Packard (3):
Save major/minor opcodes in ClientRec for RecordAReply
hw/xfree86: fix segfault in config parser when config dir is missing
Version 1.11.99.2 (1.12 snapshot 2)
Matt Turner (1):
Remove another if (E != NULL) check around free(E)
Paulo Zanoni (7):
glx: fix memory leak when destroying screen
glx: don't leak fbconfigs
glx: don't leak driConfigs
Correctly free config file names
parser: free scandir's list
parser: free val.str after xf86getBoolValue
parser: free val.str after xstrtokenize
Peter Hutterer (53):
include: fix mask size calculation
Xi: use single return code from XIPassiveGrabDevice
dix: rename GetWindowXI2Mask to WindowXI2MaskIsset
dix: use a single return statement in CheckPassiveGrabsOnWindow
Xi: add helper functions to alloc/free InputClientPtrs
Xi: add FreeInputMask function
include: add BUG_WARN macro for internal bug cases.
test: remove unneeded printf statements from misc.c
include: add list_append()
include: add list_last_entry to get the tail of a list
include: point to the tests in list.c as examples
include: a new list element does not need initialization, state so
include: update struct list documentation to use one set of structs only
include: rename "foos" to "list_of_foos" in the struct list documentation
dix: switch the syncEvent queue to a struct list
dix: add AllocGrab helper function
dix: add CopyGrab() function
dix: allocate temporary grabs on the heap
dix: switch the dev->deviceGrab.activeGrab from GrabRec to GrabPtr
Add a new XI2Mask struct and a few helper functions.
input: swap the server over to use the XI2mask struct
xfree86: bump the input ABI
dix: use BUG_WARN for input mask size issues
Xi: when removing a device, reset ClientPointers where needed
xfixes: don't dereference a NULL cursor
Xi: skip superfluous cast
Xi: check button mapping value _before_ assigning it
Xi: rename "state" to "corestate" in ProcessDeviceEvents
xfree86: include xorg-config.h from xaalocal.h
include: add BUG_WARN_MSG for custom error message on bug condition
include: add GetXI2MaskByte and GetXI2EventFilterMask to headers
Change GetXI2/XI/CoreType to just take a type argument
dix: deduplicate event delivery code
dix: replace conversion errors with BUG_WARN_MSG
dix: split grab event conversion and delivery into a helper function
dix: deduplicate callers of DeliverDeviceEvents in DeliverGrabbedEvents
Xi: deduplicate button motion mask setting
Xi: split updating button count and state into helper functions
dix: move EventDeliveryState into a header file, we'll need it elsewhere
dix: remove event type check
dix: compare the grab type, not the tempGrab type
dix: split core grab interference check into helper function
dix: move grab matching code into a helper function
dix: split out core state and event state setting into helper functions
dix: move delivery stop condition out of event mask
Add GrabIsPointerGrab and GrabIsKeyboardGrab helpers
input: replace GRABTYPE_* with the InputLevel enums
dix: always allocate and set the grab's sync.event
dix: move storing last.valuators into a helper function
dix: switch EventIsDeliverable to take the event type only
dix: move event filter retrieval helpers to inpututils.c
dix: add a MAXEVENTS define for the number of core + extension events
configure: split the required modules up
git tag: xorg-server-1.11.99.2
http://xorg.freedesktop.org/archive/individual/xserver/xorg-server-1.11.99.2.tar.bz2
MD5: 6814b7d84fb74abdb05dab900971ba00 xorg-server-1.11.99.2.tar.bz2
SHA1: feed38c8f06b4149e454d8521c03d57dd4d5ac09 xorg-server-1.11.99.2.tar.bz2
SHA256: 070a292e712560027800065744d49d7719dbac6bc0fe34ca483a6e894e37a084 xorg-server-1.11.99.2.tar.bz2
http://xorg.freedesktop.org/archive/individual/xserver/xorg-server-1.11.99.2.tar.gz
MD5: af62e0e28a8bb06fca19503b46f44472 xorg-server-1.11.99.2.tar.gz
SHA1: 47c83d210a7ec0ae8c1457d21d2c80f7635f4df6 xorg-server-1.11.99.2.tar.gz
SHA256: 5f1232a99ec718546d00260f5f6b10b9fad1fd5ed619a23f21b59161a5c5ea1c xorg-server-1.11.99.2.tar.gz
--
keith.packard at intel.com
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 827 bytes
Desc: not available
URL: <http://lists.freedesktop.org/archives/xorg-announce/attachments/20111217/86582dff/attachment.pgp>
More information about the xorg-announce
mailing list