Xorg configuration

Joe dev at freedomcircle.net
Mon Jul 10 12:34:55 PDT 2006

Hi again,

Joe wrote:
> I sent the following to questions at freebsd.org and got no replies.  I'm
> not sure if this is the right list to raise these issues or whether
> there is a more specialized list, or whether I should take this up with
> KDE once I get that running again.  So I apologize beforehand if this is
> the wrong place and I'd be grateful if someone would be kind enough to
> redirect me to the proper venue.

I still haven't received a reply from either questions at freebsd.org or 
from this list, but in the meantime I tried to run KDE.  The first time 
it took over 30 minutes to draw the initial logon screen.  Examining 
/var/log/Xlog.0.log I found a multitude of error messages like this one:

(EE) R128(0): R128CCEWaitForIdle: (DEBUG) CCE idle took i = 1025
(EE) R128(0): Idle timed out, resetting engine...

Then came four "Failed to switch consoles (Invalid argument)" messages 
which I presume was when --tired of waiting-- I pressed Ctrl-Alt-F1. 
Then some more R128CCEWaitForIdle messages followed almost at the end by:

(II) R128(0): [drm] removed 1 reserved context for kernel
(II) R128(0): [drm] unmapping 8192 bytes of SAREA 0xc3e78000 at 0x286b2000

I did some research on R128 and drm and found Eric Anholt's page on DRI 
(http://people.freebsd.org/~anholt/dri/troubleshooting.html).  I ran 
glxinfo and it said "direct rendering: No" so I commented out the 'Load 
"dri"' line from xorg.conf and retried.  This time KDE came up fairly 
quickly, although it still appears a bit sluggish compared to WinXP.

Although I "lucked out", I'm not satisfied with the loose ends that are 
left, so allow me to ask once again for some help or hints as where to 
find answers to my questions.  Thanks in advance for your cooperation.


More information about the xorg mailing list