[Bug 33425] New: [KMS] [R600] Video playback causes random reboots

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Mon Jan 24 12:32:23 PST 2011


           Summary: [KMS] [R600] Video playback causes random reboots
           Product: xorg
           Version: unspecified
          Platform: x86-64 (AMD64)
        OS/Version: Linux (All)
            Status: NEW
          Keywords: regression
          Severity: normal
          Priority: medium
         Component: Driver/Radeon
        AssignedTo: xorg-driver-ati at lists.x.org
        ReportedBy: jussaar at mbnet.fi
         QAContact: xorg-team at lists.x.org

Created an attachment (id=42395)
 --> (https://bugs.freedesktop.org/attachment.cgi?id=42395)
X configuration file

Video playback has started causing random reboots.

To rule out hardware failures (memory, CPU, GPU), I ran four different stress
test (listed below), all of which completed without errors.

Reboots occurred from few minutes to up to 30 to 40 minutes from the start of
the video. They have occurred both with mplayer and Adobe Flash Player plugin.

Usually there has been no log files. However, in one occurrence mplayer simply
crashed and the machine didn't reboot. I'll attach those logs in case they are

Motherboard: Gigabyte MA790XT-UD4P
Chipset: North Bridge AMD 790X / South Bridge AMD SB750
Processor: AMD Phenom II X3 720
Display adapter: Club 3D HD 4770 512MB (RV740)
Display: HP Pavilion f1940 (1280x1024)

Stress tests:

Memory: Memtest86+ durating ca. 6 hours, no errors
CPU: StressCPU2 from Phoronix Test Suite, 6 hours, completed successfully
1) 3DMark 2000 v1.1 build 340, Game 1 & Game 2 with High Detail, in continuous
loop for ca. 6 hours, no errors
2) Nexuiz test from Phoronix Test Suite, 6 hours, no errors

Distribution: ArchLinux x86-64 (rolling release, up to date)

Installed packages:
xorg-server: 1.9.2-2
xf86-video-ati: 6.13.2-2
xf86-input-evdev: 2.5.0-1
libdrm: 2.4.22-3
mesa: 7.9.0.git20101207-2
ati-dri: 7.9.0.git20101207-2
libgl: 7.9.0.git20101207-2

Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the xorg-driver-ati mailing list