[Bug 31484] EDID mapping from one device to another.

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Mon Nov 8 23:46:39 PST 2010


--- Comment #10 from Alex Deucher <agd5f at yahoo.com> 2010-11-08 23:46:39 PST ---
(In reply to comment #9)
> The following are the outputs of parsing the EDID information. The information
> provided varies depending on the querying method. The information also appears
> to be largely correct (although the internal panel is 14.1" and not 15"). I
> don't see why xrandr is getting it's information wrong.

The system bios patches some of the video bios tables at boot up depending on
what panel is attached, etc.  In your case, it seems to be patching in the
wrong ddc line as it used to work correctly with the old panel. The line that
gets patched in happens to be the same line as VGA so xrandr reads the same
edid from both outputs.  It may be that your panel doesn't have an EDID, in
which case the ddc line should not be set and the panel info from the bios
tables should be used instead.  This is what happens when you don't have an
external monitor attached as ddc fails.

monitor-get-edid uses vbe so the info it generates is not necessarily from an
EDID.  It's generated by the video bios either from an real EDID or from panel
info in the bios tables.

Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the xorg-driver-ati mailing list