glamor with xserver > 1.12

Michel Dänzer michel at
Mon Mar 11 11:23:52 PDT 2013

On Mon, 2013-03-11 at 00:25 +0400, Alex B wrote: 
> I need working glamor to get 3d acceleration on my video card (Radeon HD 7700)
> My current distribution Arch Linux provides xserver 1.13 and about to
> move on 1.14.
> Only way I found to make glamor work is to add /usr/lib/xorg/modules
> to
> So question is:
> Is it valid way to make glamor work and can be recommended for distro packaging?

I think it would be better to install in the normal lib
directory. Can you submit a glamor patch or bug report for that?

But, this is rather interesting news: So far the assumption has been
that glamor cannot work at all with current xserver. However, I cannot
reproduce the problem I reported a while ago even with xserver 1.13.0,
let alone newer versions, though I still can with the pre-1.13 Git
snapshot I reported the problem for. Apparently the problem was fixed
before the final 1.13.0 release. Was I really the only one who ever
tried this, and everyone else just took my word for it? :\

Earthling Michel Dänzer           |         
Libre software enthusiast         |          Debian, X and DRI developer

More information about the xorg-devel mailing list