drivers to de-support (was: [PATCH 2/3] Remove libpciaccess and pixman-1 from Requires)

Daniel Stone daniel at
Sat Sep 17 08:55:47 PDT 2011

On 17 September 2011 02:36, Michael <macallan1888 at> wrote:
> On Fri, 16 Sep 2011 21:13:10 -0400
> Matt Turner <mattst88 at> wrote:
>> I think we should simply maintain the drivers we care about. I'll try
>> to keep -glint going. For other drivers without any sort of
>> maintainer, I don't think anything really changes from what's going on
>> now.
> We ( as in NetBSD ) already keep a bunch of patches to a bunch of drivers namely:
> - chips. Put back basic ISA/VL support back so it can run on NetBSD/shark. It's also used in some old PowerBooks which some people still find useful ( that's PCI though )
> - we keep mach64, r128 and old radeon support going because they were used in lots of Suns and Power Macs
> - we have feature updates and fixes for almost all SBus and UPA drivers ( yes we run Xorg on almost everything )
> - we use wsfb instead of vesa wherever we have a mappable framebuffer

Any chance of seeing these patches sent and committed upstream?


More information about the xorg-devel mailing list