[PATCH 2/3] xorg-server.pc.in: Remove libpciaccess and pixman-1 from Requires

Julien Cristau jcristau at debian.org
Thu Sep 15 00:58:40 PDT 2011

On Wed, Sep 14, 2011 at 20:17:41 -0500, Jeremy Huddleston wrote:

> Every module building against xorg-server does not *Require* pixman nor
> libpciaccess.  If such modules need pixman or pciaccess, they should be
> depending on them directly rather than inheriting a dependency from
> xorg-server.
The thing is, most video drivers *do* need pixman and pciaccess, and
inherit that dependency from the server (not to mention the fact that
the server tends to hide the use of pixman_* by its own macros so it's
not obvious where the dependency belongs).  Can we fix that first?


More information about the xorg-devel mailing list